import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:--[A-Z]{2}|[A-Z]{2}(?:--|[A-Z]{2}))\\d{2}/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}\\.png$";
final String string = "ABCD12/123e4567-e89b-12d3-a456-426614174000.png\n"
+ "--CD12/123e4567-e89b-12d3-a456-426614174000.png\n"
+ "AB--12/123e4567-e89b-12d3-a456-426614174000.png\n\n"
+ "AB12--/123e4567-e89b-12d3-a456-426614174000.png\n"
+ "A-B-12/123e4567-e89b-12d3-a456-426614174000.png\n"
+ "A--D12/123e4567-e89b-12d3-a456-426614174000.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}