package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:--[A-Z]{2}|[A-Z]{2}(?:--|[A-Z]{2}))\d{2}/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}\.png$`)
var str = `ABCD12/123e4567-e89b-12d3-a456-426614174000.png
--CD12/123e4567-e89b-12d3-a456-426614174000.png
AB--12/123e4567-e89b-12d3-a456-426614174000.png
AB12--/123e4567-e89b-12d3-a456-426614174000.png
A-B-12/123e4567-e89b-12d3-a456-426614174000.png
A--D12/123e4567-e89b-12d3-a456-426614174000.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}