use strict;
my $str = 'ABCD12/123e4567-e89b-12d3-a456-426614174000.png
--CD12/123e4567-e89b-12d3-a456-426614174000.png
AB--12/123e4567-e89b-12d3-a456-426614174000.png
AB12--/123e4567-e89b-12d3-a456-426614174000.png
A-B-12/123e4567-e89b-12d3-a456-426614174000.png
A--D12/123e4567-e89b-12d3-a456-426614174000.png';
my $regex = qr~^(?:--[A-Z]{2}|[A-Z]{2}(?:--|[A-Z]{2}))\d{2}/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}\.png$~mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}