#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*[\\/\\\\])([-\w]+$)"
Local $sString = "/Hello/Stack/Overflow" & @CRLF & _
"/when/I/try/this" & @CRLF & _
"C:\on\VS_Code" & @CRLF & _
"C:\it\does\not\work" & @CRLF & _
"/can you" & @CRLF & _
"C:\help\me?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")