using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[\\/\\\\])([-\w]+$)";
string input = @"/Hello/Stack/Overflow
/when/I/try/this
C:\on\VS_Code
C:\it\does\not\work
/can you
C:\help\me?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}