$re = '/(.*[\\\\/\\\\\\\\])([-\w]+$)/m';
$str = '/Hello/Stack/Overflow
/when/I/try/this
C:\\on\\VS_Code
C:\\it\\does\\not\\work
/can you
C:\\help\\me?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);