re = /(.*[\\\/\\\\])([-\w]+$)/m
str = '/Hello/Stack/Overflow
/when/I/try/this
C:\\on\\VS_Code
C:\\it\\does\\not\\work
/can you
C:\\help\\me?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end