using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/transaction(\/(?<id>[\w-]*))?";
string input = @"/transaction
/transaction/1
/transaction/abc-123
/transaction/abc-123/any";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}