const regex = /\/transaction(\/(?<id>[\w-]*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/transaction(\\\/(?<id>[\\w-]*))?', 'gm')
const str = `/transaction
/transaction/1
/transaction/abc-123
/transaction/abc-123/any`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}