$re = '/\/transaction(\/(?<id>[\w-]*))?/m';
$str = '/transaction
/transaction/1
/transaction/abc-123
/transaction/abc-123/any';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);