package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/transaction(\/(?<id>[\w-]*))?`)
var str = `/transaction
/transaction/1
/transaction/abc-123
/transaction/abc-123/any`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}