re = /\/transaction(\/(?<id>[\w-]*))?/m
str = '/transaction
/transaction/1
/transaction/abc-123
/transaction/abc-123/any'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end