#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bstring\b(?!\.h\b)"
Local $sString = "#include <string.h>" & @CRLF & _
"#include <stdlib.h>" & @CRLF & _
"" & @CRLF & _
"char *Function(unsigned char *string, unsigned char *key)" & @CRLF & _
"{" & @CRLF & _
"unsigned int i, j;" & @CRLF & _
"" & @CRLF & _
"for (i = 0; i < s(string); i++)" & @CRLF & _
"{" & @CRLF & _
" " & @CRLF & _
" string[i] = ~ string[i];" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"return string;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")