$re = '/\bstring\b(?!\.h\b)/m';
$str = '#include <string.h>
#include <stdlib.h>
char *Function(unsigned char *string, unsigned char *key)
{
unsigned int i, j;
for (i = 0; i < s(string); i++)
{
string[i] = ~ string[i];
}
return string;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);