import re
regex = re.compile(r"\bstring\b(?!\.h\b)", flags=re.MULTILINE)
test_str = ("#include <string.h>\n"
"#include <stdlib.h>\n\n"
"char *Function(unsigned char *string, unsigned char *key)\n"
"{\n"
"unsigned int i, j;\n\n"
"for (i = 0; i < s(string); i++)\n"
"{\n"
" \n"
" string[i] = ~ string[i];\n"
"}\n\n"
"return string;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")