re = /\bstring\b(?!\.h\b)/m
str = '#include <string.h>
#include <stdlib.h>
char *Function(unsigned char *string, unsigned char *key)
{
unsigned int i, j;
for (i = 0; i < s(string); i++)
{
string[i] = ~ string[i];
}
return string;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end