import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bstring\\b(?!\\.h\\b)";
final String string = "#include <string.h>\n"
+ "#include <stdlib.h>\n\n"
+ "char *Function(unsigned char *string, unsigned char *key)\n"
+ "{\n"
+ "unsigned int i, j;\n\n"
+ "for (i = 0; i < s(string); i++)\n"
+ "{\n"
+ " \n"
+ " string[i] = ~ string[i];\n"
+ "}\n\n"
+ "return string;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}