use strict;
my $str = 'Наклонно-направленные скважины
Скважины с горизонтальным окончанием
';
my $regex = qr/(.+)/mp;
my $subst = 'col.Add "$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";