using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:https?:\/\/)?(?:www\.)?.*?\.com(?!\/(?:team|forum))\S*";
string input = @"website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www/website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}