re = /\b(?:https?:\/\/)?(?:www\.)?.*?\.com(?!\/(?:team|forum))\S*/m
str = 'website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www/website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end