const regex = /\b(?:https?:\/\/)?(?:www\.)?.*?\.com(?!\/(?:team|forum))\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:https?:\\\/\\\/)?(?:www\\.)?.*?\\.com(?!\\\/(?:team|forum))\\S*', 'gm')
const str = `website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www/website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}