using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\W_])\d+(?=\.\w+$)";
string input = @"abc_d1.txt
abc_d1_2.txt
abc_d1_14.txt
abc_d12_3344_x2_156.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}