use strict;
my $str = 'abc_d1.txt
abc_d1_2.txt
abc_d1_14.txt
abc_d12_3344_x2_156.txt';
my $regex = qr/(?<![^\W_])\d+(?=\.\w+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}