re = /(?<![^\W_])\d+(?=\.\w+$)/m
str = 'abc_d1.txt
abc_d1_2.txt
abc_d1_14.txt
abc_d12_3344_x2_156.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end