import re
regex = re.compile(r"(?<![^\W_])\d+(?=\.\w+$)", flags=re.MULTILINE)
test_str = ("abc_d1.txt\n"
"abc_d1_2.txt\n"
"abc_d1_14.txt\n"
"abc_d12_3344_x2_156.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")