$re = '/(?<![^\W_])\d+(?=\.\w+$)/m';
$str = 'abc_d1.txt
abc_d1_2.txt
abc_d1_14.txt
abc_d12_3344_x2_156.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);