using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\+62)?0?8\d{2}(\d{8})";
string substitution = @"\1";
string input = @"here is my phone 081134567890
081134567890
081134567890
081134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}