use strict;
my $str = 'here is my phone 081134567890
081134567890
081134567890
081134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890';
my $regex = qr/(?:\+62)?0?8\d{2}(\d{8})/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";