$re = '/(?:\+62)?0?8\d{2}(\d{8})/m';
$str = 'here is my phone 081134567890
081134567890
081134567890
081134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;