// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\+62)?0?8\d{2}(\d{8})").unwrap();
let string = "here is my phone 081134567890
081134567890
081134567890
081134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890
+6281134567890";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}