import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<First>\\w+?) (?# First word UNGREEDY)\n"
+ "(?> (?# Second group - see it is optional)\n"
+ " (?>_) (?# But if it exists, must start with \"_\" NON CAPTURING GROUP )\n"
+ " (?<Second>\\w+) (?# Snd then there should be a word - at least one char)\n"
+ ")* (?# remember - the group is optional)\n"
+ "\\b (?# All the puttern must finish with word boundary)";
final String string = " BRIGHTER \n"
+ " DIMMER \n\n"
+ " CYCLE_RGB \n"
+ " CYCLE_ALL \n\n"
+ " PULSE_WHITE \n"
+ " SMOOTH \n";
final String subst = "\\U${FirstUpper}\\L${FollowingUppers}\\U${SecondUpper}\\L${FollowingUppers2} = ${HexCode},";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}