// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?<First>\w+?) (?# First word UNGREEDY)
(?> (?# Second group - see it is optional)
(?>_) (?# But if it exists, must start with "_" NON CAPTURING GROUP )
(?<Second>\w+) (?# Snd then there should be a word - at least one char)
)* (?# remember - the group is optional)
\b (?# All the puttern must finish with word boundary)"#).unwrap();
let string = " BRIGHTER
DIMMER
CYCLE_RGB
CYCLE_ALL
PULSE_WHITE
SMOOTH
";
let substitution = "\\U${FirstUpper}\\L${FollowingUppers}\\U${SecondUpper}\\L${FollowingUppers2} = ${HexCode},";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}