import Foundation
let pattern = ##"""
(?<First>\w+?) (?# First word UNGREEDY)
(?> (?# Second group - see it is optional)
(?>_) (?# But if it exists, must start with "_" NON CAPTURING GROUP )
(?<Second>\w+) (?# Snd then there should be a word - at least one char)
)* (?# remember - the group is optional)
\b (?# All the puttern must finish with word boundary)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
BRIGHTER
DIMMER
CYCLE_RGB
CYCLE_ALL
PULSE_WHITE
SMOOTH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U${FirstUpper}\L${FollowingUppers}\U${SecondUpper}\L${FollowingUppers2} = ${HexCode},"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)