use strict;
my $str = ' BRIGHTER
DIMMER
CYCLE_RGB
CYCLE_ALL
PULSE_WHITE
SMOOTH
';
my $regex = qr/(?<First>\w+?) (?# First word UNGREEDY)
(?> (?# Second group - see it is optional)
(?>_) (?# But if it exists, must start with "_" NON CAPTURING GROUP )
(?<Second>\w+) (?# Snd then there should be a word - at least one char)
)* (?# remember - the group is optional)
\b (?# All the puttern must finish with word boundary)/mxp;
my $subst = '\\U${FirstUpper}\\L${FollowingUppers}\\U${SecondUpper}\\L${FollowingUppers2} = ${HexCode},';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";