const regex = new RegExp('<option value="(.*?)">(.*?)</option>', 'gs')
const str = `<option value="A">uno</option >
<option value="B">dos</ option>
<option value="C">tres</option>
<option value="A" data='foo'>uno</option>
<option value="B" data='bar'>dos</option>
<option value="C">tres</option>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}