// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<option value="(.*?)">(.*?)</option>"#).unwrap();
let string = "<option value=\"A\">uno</option >
<option value=\"B\">dos</ option>
<option value=\"C\">tres</option>
<option value=\"A\" data='foo'>uno</option>
<option value=\"B\" data='bar'>dos</option>
<option value=\"C\">tres</option>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}