re = /<option value="(.*?)">(.*?)<\/option>/
str = '<option value="A">uno</option >
<option value="B">dos</ option>
<option value="C">tres</option>
<option value="A" data=\'foo\'>uno</option>
<option value="B" data=\'bar\'>dos</option>
<option value="C">tres</option>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end