import re
regex = re.compile(r"<option value=\"(.*?)\">(.*?)</option>", flags=re.DOTALL)
test_str = ("<option value=\"A\">uno</option >\n"
"<option value=\"B\">dos</ option>\n"
"<option value=\"C\">tres</option>\n\n"
"<option value=\"A\" data='foo'>uno</option>\n"
"<option value=\"B\" data='bar'>dos</option>\n"
"<option value=\"C\">tres</option>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")