$re = '~<option value="(.*?)">(.*?)</option>~s';
$str = '<option value="A">uno</option >
<option value="B">dos</ option>
<option value="C">tres</option>
<option value="A" data=\'foo\'>uno</option>
<option value="B" data=\'bar\'>dos</option>
<option value="C">tres</option>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);