#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\bUnternehmergesellschaft\b|\bUG haftungsbeschränkt\b|\bUG (haftungsbeschränkt)\b|\bUG\b|\bUnternehmergesellschaft und Compagnie Kommanditgesellschaft\b|\bUG & Co. KG\b)"
Local $sString = "########## Try to match all these German company titles ###########" & @CRLF & _
"" & @CRLF & _
"company title: Unternehmergesellschaft" & @CRLF & _
"company title... UG haftungsbeschränkt" & @CRLF & _
"company title == UG (haftungsbeschränkt)" & @CRLF & _
"company title --> UG" & @CRLF & _
"company title Unternehmergesellschaft und Compagnie Kommanditgesellschaft" & @CRLF & _
"company title:UG & Co. KG" & @CRLF & _
"company title = UG & Co.KG" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")