// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\bUnternehmergesellschaft\b|\bUG haftungsbeschränkt\b|\bUG (haftungsbeschränkt)\b|\bUG\b|\bUnternehmergesellschaft und Compagnie Kommanditgesellschaft\b|\bUG & Co. KG\b)").unwrap();
let string = "########## Try to match all these German company titles ###########
company title: Unternehmergesellschaft
company title... UG haftungsbeschränkt
company title == UG (haftungsbeschränkt)
company title --> UG
company title Unternehmergesellschaft und Compagnie Kommanditgesellschaft
company title:UG & Co. KG
company title = UG & Co.KG
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}