const regex = new RegExp('(\\bUnternehmergesellschaft\\b|\\bUG haftungsbeschränkt\\b|\\bUG (haftungsbeschränkt)\\b|\\bUG\\b|\\bUnternehmergesellschaft und Compagnie Kommanditgesellschaft\\b|\\bUG & Co. KG\\b)', 'gm')
const str = `########## Try to match all these German company titles ###########
company title: Unternehmergesellschaft
company title... UG haftungsbeschränkt
company title == UG (haftungsbeschränkt)
company title --> UG
company title Unternehmergesellschaft und Compagnie Kommanditgesellschaft
company title:UG & Co. KG
company title = UG & Co.KG
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}