re = /(\bUnternehmergesellschaft\b|\bUG haftungsbeschränkt\b|\bUG (haftungsbeschränkt)\b|\bUG\b|\bUnternehmergesellschaft und Compagnie Kommanditgesellschaft\b|\bUG & Co. KG\b)/m
str = '########## Try to match all these German company titles ###########
company title: Unternehmergesellschaft
company title... UG haftungsbeschränkt
company title == UG (haftungsbeschränkt)
company title --> UG
company title Unternehmergesellschaft und Compagnie Kommanditgesellschaft
company title:UG & Co. KG
company title = UG & Co.KG
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end