use strict;
my $str = '########## Try to match all these German company titles ###########
company title: Unternehmergesellschaft
company title... UG haftungsbeschränkt
company title == UG (haftungsbeschränkt)
company title --> UG
company title Unternehmergesellschaft und Compagnie Kommanditgesellschaft
company title:UG & Co. KG
company title = UG & Co.KG
';
my $regex = qr/(\bUnternehmergesellschaft\b|\bUG haftungsbeschränkt\b|\bUG (haftungsbeschränkt)\b|\bUG\b|\bUnternehmergesellschaft und Compagnie Kommanditgesellschaft\b|\bUG & Co. KG\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}