using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(\s|\b)users:\[)([a-zA-Z0-9_, ]*)(?=\])";
string input = @"user:Lagoffre
users:[Lagoffre, Lagoffre] xqlkfdjd
qlksjd user:Lagoffre| hfghgj
qksjdh users:[Lagoffre, Lagoffre]qsdlkjdlqskjdqs
qsd wuser:Lagoffre
qsd wusers:[Lagoffre, Lagoffre]
qsd user:Lagoffre jhb
qsd users:[Lagoffre, Lagoffre]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}