re = /(?<=(\s|\b)users:\[)([a-zA-Z0-9_, ]*)(?=\])/m
str = 'user:Lagoffre
users:[Lagoffre, Lagoffre] xqlkfdjd
qlksjd user:Lagoffre| hfghgj
qksjdh users:[Lagoffre, Lagoffre]qsdlkjdlqskjdqs
qsd wuser:Lagoffre
qsd wusers:[Lagoffre, Lagoffre]
qsd user:Lagoffre jhb
qsd users:[Lagoffre, Lagoffre]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end