import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(\\s|\\b)users:\\[)([a-zA-Z0-9_, ]*)(?=\\])";
final String string = "user:Lagoffre\n"
+ "users:[Lagoffre, Lagoffre] xqlkfdjd\n\n"
+ "qlksjd user:Lagoffre| hfghgj\n"
+ "qksjdh users:[Lagoffre, Lagoffre]qsdlkjdlqskjdqs\n\n"
+ "qsd wuser:Lagoffre\n"
+ "qsd wusers:[Lagoffre, Lagoffre]\n\n"
+ "qsd user:Lagoffre jhb\n"
+ "qsd users:[Lagoffre, Lagoffre]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}