$re = '/(?<=(\s|\b)users:\[)([a-zA-Z0-9_, ]*)(?=\])/m';
$str = 'user:Lagoffre
users:[Lagoffre, Lagoffre] xqlkfdjd
qlksjd user:Lagoffre| hfghgj
qksjdh users:[Lagoffre, Lagoffre]qsdlkjdlqskjdqs
qsd wuser:Lagoffre
qsd wusers:[Lagoffre, Lagoffre]
qsd user:Lagoffre jhb
qsd users:[Lagoffre, Lagoffre]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);