import re
regex = re.compile(r"(?<=(\s|\b)users:\[)([a-zA-Z0-9_, ]*)(?=\])", flags=re.MULTILINE)
test_str = ("user:Lagoffre\n"
"users:[Lagoffre, Lagoffre] xqlkfdjd\n\n"
"qlksjd user:Lagoffre| hfghgj\n"
"qksjdh users:[Lagoffre, Lagoffre]qsdlkjdlqskjdqs\n\n"
"qsd wuser:Lagoffre\n"
"qsd wusers:[Lagoffre, Lagoffre]\n\n"
"qsd user:Lagoffre jhb\n"
"qsd users:[Lagoffre, Lagoffre]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")