#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*;(.*);.*$"
Local $sString = "220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad" & @CRLF & _
"220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad" & @CRLF & _
"221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore" & @CRLF & _
"222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")